UPDATE: Last library re-extracted from ChromeOS on: 9-8-19 — confirmed that DRM works perfectly (ex, Spotify, etc), but as a Netflix solution it does *NOT* currently work with the latest version of Chromium (74.0.3729.157)! This may be due to “stable” having moved to 76, and raspbian still rocking the 74 branch.

The Raspberry Pi 4 model with 4GB of RAM is the first cheap hardware that can provide a real “desktop-like” experience when browsing the web/watching Netflix/etc. However, if you have tried to run Netflix on the Pi, you have quickly entered the disgusting mess that exists around DRM, WideVine (Netflix being one example of something that needs it), and Chromium.

After hours and hours of effort, I finally discovered a quick and elegant solution that lets you use the latest default provided Chromium browser, without having to recompile anything in order to watch any WideVine/DRM (Netflix, Spotify, etc) content.

Background and the DRM Problem

If you are not familiar with this, the short version is that Netflix (and many others, ex: Spotify) use the WideVine “Content Protection System” – aka DRM, and if you want to watch Netflix or something else that uses it, you need to have a WideVine plugin+browse supported integration. Chrome, Firefox, and Safari make it available for x86/amd64 systems, but not for ARM since technically they don’t have ARM builds.

Chromium, the project Chrome is based on, does have an ARM build, but it does not include any DRM support, and technically it does not include widevine support by default (*caveat here, which helps us later)
So long story short, the question becomes “how do you enable DRM/WideVine support in Chromium?”.

It seems there are two main solutions out there: use an old (v51, 55, 56, 60) version of Chromium which has been “patched” with widevine support (kusti8’s version seems to be the most popular one – except since the new Netflix changes, that also does not work), which requires uninstalling the latest Chromium available, installing the old/patched one, and dropping in older widewine plugins; the second option is to use Vivaldi – a proprietary fork of Opera which also has been “sort of patched”, but it still needs a valid libwidevinecdm plugin (see bellow) and it has it’s own issues (and also…it’s Opera…in 2019…who uses Opera?)

After a lot of research and trial and error, I discovered a much more elegant solution – use the extracted ChromeOS (armv7l – yay) binaries and insert them into Chromium + make everything think it’s ChromeOS (user agent)

Netflix/Spotify with the Default Raspberry Pi Chromium Browser


1.) Download the latest extracted ChromeOS libwidevine binary and extract it:

NOTE: You can verify that these are the *official* versions from ChromeOS:
https://dl.google.com/dl/edgedl/chromeos/recovery/chromeos_12239.92.0_elm_recovery_stable-channel_mp-v2.bin.zip

NOTE: UPDATED (Last re-extracted from ChromeOS on: 9-8-19)
filename: libwidevinecdm.so
md5sum: 41c94b9ffa735fe4f412b7e9283dd2ff
sha256sum: 2245a2f5ba8452692e79f478d64adbeedaef5307cc73e81ffe64de69a7a53640

2.) Completely QUIT all Chromium windows and re-start it.
Grab the “User-Agent Switcher for Chrome” extension: https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg

Right click on the extension, go to “Options” and “Add” the following in the fields:
a.) New User-agent name: Netflix
b.) New User-Agent String: Mozilla/5.0 (X11; CrOS x86_64 11895.95.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.157 Safari/537.36
c.) Group: Chrome
d.) Append: Replace
e.) Indicator Flag: NFX

3.) Open a new tab, select the “NFX” profile (one time) from the User-Agent Switcher, and go to: https://bitmovin.com/demos/drm
You should be able to see the movie on the left. You can now play Netflix, and Spotify

Please note that If you can see the vide on the left, this means the DRM plugin has worked! From this point on, anything that does not work (ex: Netflix sometimes breaks after a browser update) is due to the site specifically filtering User Agents/doing other “tricks”. So for example, if Netflix does not work, Spotify, Hulu, Amazon, HBO, etc will still work. The BitMovin website is the “real” test on wether the DRM plugin has worked.

Solution if you see occasional “screen tearing”
It seems the Pi’s raw CPU frequency is still not powerful enough for decoding 100% of the time. While 97-98% of the time is good enough, you will get the occasional “screen tearing” (https://en.wikipedia.org/wiki/Screen_tearing), especially with scenes with fast motion.

User Tim (credit to him for finding this!) may have found the solution to this:

Ok think i have a fix. Netflix in Chrome will only play 1280 x 720 max (its a known thing) and can be checked by pressing CTRL SHIFT ALT and D when the video is playing in Netflix (for Vid stats).
So as a test i changed my pi screen configuration from 1920 x 1080 to 1280 x 720 (at 59.94 HZ) and netflix plays fine with no tearing. (the tearing was mostly present when the camera pans left to right etc). For some reason my monitor has a 1280 x 720 at 60HZ option but this also gave a little tearing, the 59.94Hz option cures it completely, this works for me and i am happy watching Netflix at 720p

Update to this: It seems Netflix will only play at 720p on Chrome, so by lowing the resolution, it removes tearing in the cases where the monitor is at a higher resolution/60Hz.

Older Versions
Here are the last few OLDER versions in case you need them (note the unique date in the url):
http://blog.vpetkov.net/wp-content/uploads/2019/08/libwidevinecdm.so_.zip
http://blog.vpetkov.net/wp-content/uploads/2019/07/libwidevinecdm.so_.zip

123 Thoughts on “Netflix and Spotify on a Raspberry Pi 4 with Latest Default Chromium

  1. Perfect solution. Even intalling the fix remotely through Putty and Teamviewer worked like a charm. Thanks a bunch from Hamburg Germany

  2. Thanks…
    Well documented !

    It’s working now.

    A +
    JOEL

  3. Wired Life on August 26, 2019 at 3:53 pm said:

    Can you explain how to set the resolution and 59.94 HZ?
    I dont get it…
    Thanks!

  4. Thanks a lot, it works.
    My only complaint: Still get a lot of screen tearing. Tried to follow Tim’s tipp but I’m not offered 59.94Hz. Only 60Hz or 50Hz… (Living in Germany, not sure if that might be the reason?)

  5. Worked like a charm. Netflix is running now although on raspi 4 with 4gb ram (512 on vid) it is a bit laggy but still working so i don’t complain;)

  6. I also have no problem watching Netflix with the new setup. Very nice indeed.

    I just started subscribing to HBONOW. Do you have a user agent string that will work for HBO? Getting unsupported browser comment when attempting to play.

    Regards,

  7. I followed this BS Vivaldi how-to which didn’t work. This had Netflix running in 3 minutes after following yours. My sanity thanks you.

    • Rick – Thanks!
      It’s funny, the whole reason I put this blog post together was because I also came from the Vivaldi stupidity. I figured if it pissed me off, it probably pissed off a whole bunch of other people.

  8. works great. Temp while playing movies is stable at 38C. I use a small heatsink and fan.

    Spotify as well works and also shows mini player popup now! Great find and tanks for the work.

  9. cascabel on August 18, 2019 at 8:13 am said:

    On the Raspberry, download the libwidevinecdm.so_.zip file at /home/pi/Downloads:

    http://blog.vpetkov.net/wp-content/uploads/2019/08/libwidevinecdm.so_.zip

    Open a terminal and type the following commands:

    cd Downloads
    unzip libwidevinecdm.so_.zip
    cd /usr/lib/chromium-browser
    sudo rm libwidevinecdm.so
    sudo cp /home/pi/Downloads/libwidevinecdm.so .

    • cascabel – your way definitely works, but I would suggest saving a fee steps. In the terminal directly doing a “sudo su”, then “# cd /usr/lib/chromium-browser” and then just wget and unzip there and chmod.

      It should save you a few steps.

  10. Thanks. I’ll give it a try to extract it myself. I am a retired IT guy that was playing with AT&T Unix back around 1986. Not a full on Linux wizard but I can usually muddle through. When I can’t my oldest runs a super computer in Cheyenne from Boulder. He is my tech support.

    Dave

  11. Spotify
    Today I got spotify does not support your browser, All I did was updated to the august libwidevinecdm.so and now its all OK. Thank you!!!

    • Great to hear – thanks for the feedback. Now that I know that Google is constantly pushing a new version, I’ll stay on top of it and keep re-extracting it. Ping me here if it ever changes, this feed back is really helpful.

  12. Rights are working again on Channel4.com. You might want to add a warning that if the old .zip is in the directory the new file will download as .zip.1. Now to figure out why the full screen button doesn’t work on itv.com. I suspect something to do with the new version and the string.

    What is your process for getting the new file? I would like to be able to do it myself if needed.

    Dave

    • Dave – it’s funny, I assumed permissions (chmod) is just second nature to linux users, but the problem is every pi user is not always a linux user 🙂
      That said – you can pull it from the official Google source tree. The process is a bit “involved” – not so much that it’s hard, but you do need to have deep understanding of linux.

      I can do a 30K foot overview, but not sure how helpful that will be.
      Start here: https://dl.google.com/dl/edgedl/chromeos/recovery/recovery.conf — pull the latest version, and from there extract the source tree.
      Pull the latest version number, grab the recovery source from that, and pull the bootable recovery image out of that, extract it, decompress it, and create a chromeos disk image.
      From there, you have to scan the partition table and mount just the libraries partition in the image via a loopback device driver. I think this is the 3rd partition currently.
      Once you have this, create a temporary file system and extract “opt/google/chrome/libwidevinecdm.so” out of that.

  13. For the people that downloaded the plugin in the past 24 hours (8-16-19) — it looks like I forgot to chmod it before zipping to distribute it.

    Please just run as root:

    # chmod 755 /usr/lib/chromium-browser/libwidevinecdm.so

  14. Still get an error DRM_FAILED_LICENSE_REQUEST on the stream test and error C7121-1331 in Netflix. I am sure I copied the UA string correctly. Is it still working fine for you?
    So in 2019 we still use the nice parts of Opera?

    • Alex – Please check the plugin permissions. It seems they did not “save” into the zip file (already updated and re-uploaded).
      But you can manually just:

      When you:

      it needs to look like:
      -rwxr-xr-x 1 root root 6.6M Aug 15 23:48 libwidevinecdm.so

      ps: There are no nice parts of Opera 😉

  15. Ansgar Maehrlein on August 16, 2019 at 5:08 am said:

    I found one thing missing in the otherwise excellent guide: after unzipping libwidevinecdm.so, it needs to be made readable with the following command (still as superuser):
    “chmod +r libwidevinecdm.so”

    • Just saw this post – great catch – thanks! (see previous about chmod 755). I’ll update the blog post too in case it doesn’t save in the zip.

  16. Ansgar Mährlein on August 16, 2019 at 4:38 am said:

    Hey, i tried getting netflix to run on my pi 4b 4GB using your guide, however the test video page shows “Detected ?, using widevine” above the player, and “Unable to instantiate a key system supporting the required combinations (DRM_NO_KEY_SYSTEM)” in the player.
    Netflix, when trying to play a movie, tells me:
    “Whoops, something went wrong…

    Missing Component

    We cannot find all the required components to play Netflix on this device.
    Please visit chrome://plugins, ensure that both the “Netflix” and the “Widevine Content Decryption Module” plug-ins are enabled and their “Always allowed” setting is checked.

    For additional assistance in resolving this issue, please visit our Help Center.

    Error Code: C7702-1003″

    “chrome://plugins” does apparently not exist in Chromium, however “chrome://components”, which seems to have replaced it, does neither show the “Netflix”, nor the “Widevine Content Decryption Module”.
    I tried restarting chromium, restarting raspbian and clearing the netflix cookie as suggested on Netflix’s help page for the error code C7702-1003, this didn’t change anything.

    It is a fresh raspbian install and i updated all software to the newest versions just now.
    I have also updated the usb controller firmware to the newest version.
    The only extensions i added to chromium in addition to the pre-installed ones are LastPass and PawHash (and Chrome UA Spoofer from your guide).
    Disabling the preinstalled UBlock Origin on the test page makes no difference.
    I followed the instructions verbatim, the libwidevine version is the one from 15.08.2019 and the user agent was copied exactly.
    Chromium is “Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit)”
    I additionally tried to make libwidevine executable using chmod +x to no avail.

    Do you have any idea what could be the cause/solution or do you need/want any more debugging/ information?
    Thanks for your help in advance and thanks for making the guide in the first place,
    Ansgar

    • Ansgar – Please check the plugin permissions. It seems they did not “save” into the zip file (already updated and re-uploaded).
      But you can manually just:

      When you:

      it needs to look like:
      -rwxr-xr-x 1 root root 6.6M Aug 15 23:48 libwidevinecdm.so

  17. The most recent steps didn’t work for me until I changed the permissions for the libwidevinecdm.so file. For some reason, chromium was not able to read the file. I went with 777 as I didn’t want to care much about it so I am sure there might be a better way of doing it.
    Right after unziping, the perms were -rwxr-x--- 1 root root 6829784 Aug 16 04:56 libwidevinecdm.so

    • maara – Please check the plugin permissions. It seems they did not “save” into the zip file (already updated and re-uploaded).
      But you can manually just:

      When you:

      it needs to look like:
      -rwxr-xr-x 1 root root 6.6M Aug 15 23:48 libwidevinecdm.so

  18. While this was working fine, I can’t get it working on chromium 74.0.3729.157 and the most recent version of the library. the test drm movie is saying DRM_NO_KEY_SYSTEM

  19. For everyone that has subscribed to comments/updates (thank you by the way!) – an update you may enjoy: I just re-extracted the *LATEST* version of the library (as of 8-15-19).

    Updated main download link: http://blog.vpetkov.net/wp-content/uploads/2019/08/libwidevinecdm.so_.zip
    Please note the new MD5 and SHA256 checksums:
    md5sum: 41c94b9ffa735fe4f412b7e9283dd2ff
    sha256sum: 2245a2f5ba8452692e79f478d64adbeedaef5307cc73e81ffe64de69a7a53640

    Also, created a section in the post with the old versions in case someone needs them.
    In this case, the older version is:
    http://blog.vpetkov.net/wp-content/uploads/2019/07/libwidevinecdm.so_.zip
    md5sum: 4946f3c49c7ce5cd129e66c61aab28a4
    sha256sum: 2bba50467ff582e30994114acd5a417016161fc81bfa127c2a15e807f700bf1b

  20. It has been at least a couple of days. I just rechecked an episode that worked on Saturday and is not working tonight.

    • Dave – seems like they released a new version of Chromium and packaged a new version of the plugin. Just finished extracting it 🙂 — see my updated link the blog post (note the new date/url)

  21. I tried redownloading both Wildvine and replacing the user agent. The UA string is a copy/paste of the instructions. I don’t use it for Hulu. I am streaming UK BBC/ITV/Channel4 off a proxy server in London. All were working really well until Channel4 started complaining about rights and ITV lost the ability to go full screen. When I run the test video it has a header of Detected ?, using wildvine above where the video would play. I don’t remember what it had before, it worked so I jumped into using it. I am not sure what version of Chromium was in the original install. I may end up loading another SD card to go back.

    • Ill check the test video to see if there is a header. Ill also re-extract the latest official build from ChromeOS to make sure something has not updated in the last 24ish hours.

  22. I had everything working until a few days ago. Then one of my streaming sources started compliaing about rights. At the same time another stopped swithcing to full screen mode. Not sure if it was related. I had done an apt-get update but didn’t notice the problem right away. I may not have used the soruces right after the update. I just did an update that didn’t do anything and an apt-get upgade that downloaded a lot of stuff. I am still broken. Any hints as to where to start looking would be great. Data below.

    Demo video error message
    License request failed
    (DRM_FAILED_LICENSE_REQUEST)

    Chromium version – Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit)c

    Spoofer string – Mozilla/5.0 (X11; CrOS x86_64 11895.95.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.125 Safari/537.36

    Dave

    • Dave – try to re-add the plugin in case it got removed with an update.

      Check your spoofed string – you can update to match Chromium version, but mine is your version and I have your version of Chromium and it works.

  23. Raspiness on August 15, 2019 at 5:20 pm said:

    I will say first, thank you for this. It was worked out great! Until today really. Netflix loads up just fine. Hulu is another story. Error: DRMCDM78

    Can’t help but think it’s related to the set up I have going.

    Anyway, I’m on RP4 with latest Chromium and even double-checked the widevine file. No luck.

    • Did Hulu work before? (I had not tested it)
      Did the browser upgrade/something change?

      My suggestion is to re drop the plugin, check user agent string, etc.

  24. Sir LeveL on August 15, 2019 at 11:50 am said:

    ventz i have chromium 72
    also was able to ply that drm video
    but netflix showing error—-
    error code M7121-1331
    plz help i’m a total noob

    • Check agent string carefully and make sure its then selected. Quit Chromium and restart.

      If the test video works, the plugin is all set and its just your agent string which Netflix needs to match.

  25. No longer working for me. Says the browser is out of date, any fix?

    • Bob – check your user agent/switcher.
      Double check that you have the correct plugin, and chmod.

      I am om Chromium 74.0.3729.157 (Official Build), which seems to be the latest, and its running here.

  26. Test video wouldn’t play; however, got both Netflix and Amazon Prime to play…finally. This makes it so much easier than carrying a laptop when I travel weekly for work, easily running on the hotel TV. Thanks for the great instructions!

  27. Kabadisha on August 13, 2019 at 7:16 am said:

    Fan noise is tiny. Can’t hear it at all.
    The fan shim is crap, I tried it. It kept stopping randomly. That heatsink and fan arrangement is much better. Temps only get to 55 celcius after playing a full film at 1080p on Kodi.

  28. motthomas on August 13, 2019 at 6:46 am said:

    Great! Thank you both for your feedback. You are right, the price difference is not that much for the 4GB, especially if it is likely I will need it.
    Kabadisha – Thanks for link to the heatsink/fan case. I had been looking at the fan shim from Pimoroni but then I would still need a case. It looks like the fans are always powered on with the case you linked. How do you find the fan noise? Is it noticeable?

  29. motthomas on August 12, 2019 at 7:51 am said:

    Thanks for the guide! I was about to give up on a proper RPi AVOD media player until I found this. I tested it on an RPi 3B+ but performance was not great as mentioned above. The picture was not smooth enough to be watchable.

    It has given me confidence to upgrade to an RPi 4 though. The only question is how much RAM do you recommend? Is the 1Gb sufficient? There is mention of 4Gb above but just wondering if that is needed… 2Gb may be a good compromise?

  30. Damodaran M V on August 10, 2019 at 11:47 am said:

    Hello friends,
    I have tried this method in my Raspberry pi 3 model B. with slight overclocking. My overclocking section in the /boot/config.txt file; A small & cheap aluminium heatsink and fan attached for cooling. he temperature remains well under 50 Degree Celsius all the time.
    ### !!!! Overclocking section 10-08-2019 !!!!
    arm_freq=1200
    core_freq=500
    sdram_freq=500
    over_voltage=600

    No overclocking in arm_freq section.
    the prime video plays more or less good.
    Hence this seems a great work around for arm boards.
    My next attempt is to try this with an Odroid c2 board. thanks once again Mr. Steffen

  31. Working well for me. Thanks.

  32. Steffen on August 9, 2019 at 5:00 am said:

    Thanks <333

    After a fresh install of my RP4 your guidance works well!:)
    tried several older guidance's before testing this one, so my chromium were probably messed up;)

  33. Working
    raspberry pi 3b
    chromium 72
    “Raspbian GNU/Linux 9 (stretch)”

  34. Steffen on August 8, 2019 at 5:03 am said:

    The test video wont start. receiving this DRM error:
    Unable to instantiate a key system supporting the required combinations
    (DRM_NO_KEY_SYSTEM)

    However my netflix now gives me an different error; “missing components” C7702-1003

    any clue?

    • Steffen – a few things:
      * update your raspbian system and go through the steps again
      * something was not done correctly (file/location/permissions/etc) or you have a typo somewhere in the user agent string/etc.
      * try also closing/quitting the browser completely and re-opening

  35. Ok think i have a fix. Netflix in Chrome will only play 1280 x 720 max (its a known thing) and can be checked by pressing CTRL SHIFT ALT and D when the video is playing in Netflix (for Vid stats).
    So as a test i changed my pi screen configuration from 1920 x 1080 to 1280 x 720 (at 59.94 HZ) and netflix plays fine with no tearing. (the tearing was mostly present when the camera pans left to right etc). For some reason my monitor has a 1280 x 720 at 60HZ option but this also gave a little tearing, the 59.94Hz option cures it completly, this works for me and i am happy watching Netflix at 720p
    plus i can change my pi resolution back once i have finished watching Netflix.
    PS There is a chrome app called Super Netflix which used to allow the user to change the Netflix resolution to 1080 but it no longer seems to work

    • Netflix in Chrome will only play 1280 x 720 max (its a known thing) and can be checked by pressing CTRL SHIFT ALT and D when the video is playing in Netflix (for Vid stats).
      So as a test i changed my pi screen configuration from 1920 x 1080 to 1280 x 720 (at 59.94 HZ) and netflix plays fine with no tearing.

      That is really good to know! Thanks.
      I am going to update the post with this info on the bottom.

      For anyone on a Mac by the way, it’s “ctrl + shift + option + d”

  36. Ive tried netflix again with a 1750 cpu overclock and a 600 gpu overclock, and the horizontal screen tearing is still there. CPU temp is around 50 so its not getting too hot. the same problem can also be seen in youtube videos

    • Tim – thanks, this is really good to know. It seems like the Pi really needs to boost the raw CPU freq at least to 2(ish)…maybe even 2.3.

      I wonder if the 4K comes into play also. For example, I haven’t seen this happen with YouTube on my side yet, but I did see it with Netflix.

  37. Dennis on August 5, 2019 at 5:59 am said:

    Just to inform you that it works on the RPI 3B+ too. It’s just too slow to be actually watchable. But it works. Thanks for the guide! (Maybe I now have a reason to upgrade to a RPI 4 😀 )

  38. Thanks man! It works after reinstalling Raspian. Now im waiting for my case to cool down the PI.

  39. Damodaran M V on August 4, 2019 at 8:19 am said:

    Damodaran M V form India
    Great, I am using RPi4 4GB and Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit)
    The steps mentioned above worked well. The video looks OK but not perfect. But your Information and the work is heartly appreciated. Thanks.

    • Ventz on August 4, 2019 at 9:05 am said:

      Damodaran – it seems the CPU is just not fast enough. Try overclocking it from the raspi-comfig and attaching a heatsink (potentially one with a fan). I keep hearing that that makes it perfect.

  40. Not working. Error “C7702-1003” 🙁

    • Ventz on August 4, 2019 at 9:09 am said:

      Tobi – that means you still have the old session cookies from before the plugin. Quit and reopen the browser.

      If that doesn’t work, try the steps again carefully. At last flush cookies/cache and quit+reopen the browser (fully).

  41. Sebby on July 31, 2019 at 7:34 am said:

    God bless you! I was this close to throw my Raspberry out of the window and delete this project of mine i’m working on! This solution was quick, clear and easy to implement, also works like a charm for running the sdk spotify webplayer, you saved the whole project, thanks!!

  42. Hi.
    Nice to read this post.
    Have you had a try on ARD, ZDF, Arte (Germany) Mediatheken or Raiplay (Italy)?
    Can you select on ARD, ZDF, Arte the available subtitles?
    That’s really important for me.
    If it works on full screen, I’ll buy soon a RPI 4B 4GB.

    Thanks!

  43. Yoda on July 26, 2019 at 4:50 pm said:

    Thanks for the guide – works great!
    Any update on the tearing?

    • Ventz on July 26, 2019 at 5:07 pm said:

      Seems like “cooling” the cpu (dispersing heat) via a heatsink and potentially even overclocking the cpu too.

      Haven’t tried it myself yet, but a couple of people mentioned that this solved the problem. It seems the Pi 4 is still sadly slightly underpowered on the raw cpu frequency side.

      But for anything that takes advantage of the gpu offload, it should be perfect even at 4K.

  44. FooBarBaz on July 23, 2019 at 3:49 pm said:

    Ahh… spoke too soon. Netflix works, but other stuff is broken! Youtube, BBC IPlayer both fail as soon as I start to play something, freezing Chromium completely. Removing the libwidevinecdm.so file and setting the user agent back to Chrome->default seems to fix the issues. Pity you can’t have all working simultaneously!

    • Ventz on July 23, 2019 at 7:52 pm said:

      Strange – youtube should be completely independent of all of this.

      Try switching your agent profile for youtube. This is only an add-on so it really should not break anything else since by default the ability is essentially not there.

  45. FooBarBaz on July 23, 2019 at 1:10 pm said:

    Just to confirm instructions work on RPI 4 with Raspbian 10 and Chromium Version 74.0.3729.157 (Official Build). Thanks, nice work!

    • Ventz on July 23, 2019 at 2:23 pm said:

      FooBarBaz – Awesome! Glad it’s working and you found it helpful!
      (thanks for confirming Chromium version too!)

  46. Superb job. Works like a charm 🙂

    FYI, I added a fan to my Raspberry Pi v4 and I don’t get any artifacts when running Netflix or Amazon Prime at 1080p

    • Ventz on July 21, 2019 at 6:49 pm said:

      Kabadisha – awesome, thanks.

      That is *really* good to know! I wonder if overclocking it a bit with a heatsink would help even more. Thanks for providing this info.

  47. nish on July 20, 2019 at 5:13 pm said:

    Dude such a life saver. Thank you for putting this together. Was able to create a spotify endpoint running on chromium on pi3.

  48. thanks this works on the pi4 and the most recent rasbian buster image has hardware accelertion enabled in Chromium. BUT there is a lot of horizontal video tearing in Netflxi any idea how to fix this?

    • Ventz on July 19, 2019 at 9:37 am said:

      Tim – I noticed the same and I wonder if the hardware acceleration is actually the problem. Its almost like the hardware cant keep up with high def content when there is motion. If you try watching something without much motion, it seems ok. I am trying to figure this out too.

  49. Wisegi on July 18, 2019 at 5:43 pm said:

    Well the demo video worked but netflix is still not working. I did the steps exactly as I was told. I think. Thoughts?

    • Ventz on July 18, 2019 at 5:59 pm said:

      Try flushing the browser – if the test video worked, Netflix should work (uses the same drm.)

      Double check that you restarted the browser too. Double check the User Agent string. Check the permissions on the files.

      I’ve gotten emails from a few thousand people that it worked for them, so it has to be something small (typo, etc)

  50. BabySaurus on July 18, 2019 at 2:04 pm said:

    Thanks !
    It perfectly works !

    • Ventz on July 18, 2019 at 3:15 pm said:

      Awesome – glad it’s working! Personally, love how quick and easy (and secure!) this is compared to the alternatives.

Comment navigation

 

Leave a Reply to Sir LeveL Cancel reply

Your email address will not be published. Required fields are marked *

Post Navigation